木曜日, 4月 17, 2008

mumbleサーバ構築編

root@lexio:~# dpkg -i mumble-server_1.1.3-0ubuntu1_i386.deb
未選択パッケージ mumble-server を選択しています。
(データベースを読み込んでいます ... 現在 17968 個のファイルとディレクトリがインストールされています。)
(mumble-server_1.1.3-0ubuntu1_i386.deb から) mumble-server を展開しています...
dpkg: 依存関係の問題により mumble-server の設定ができません:
mumble-server は以下に依存 (depends) します: libqt4-core (>= 4.3.2) ...しかし:
パッケージ libqt4-core はまだインストールされていません。
mumble-server は以下に依存 (depends) します: libqt4-sql (>= 4.3.2) ...しかし:
パッケージ libqt4-sql はまだインストールされていません。
dpkg: mumble-server の処理中にエラーが発生しました (--install):
依存関係の問題 - 設定を見送ります
以下のパッケージの処理中にエラ
だそうです。

水曜日, 4月 16, 2008

railsを使っていて

今私は現在rails1.2.6でajaxonrailsを勉強中なのですが、そこで2日くらい困った症状が起こりました。
それは今となっては解決した既知の事項なのですが、rails初心者が落ち入りやすいと思ったので残しておきます。

何もブラウザ上で出力されない問題

rails_rootのしたにあるapp/views/layout
ここには、すべてのビューに対しての出力の方法を明記するのですが、ここで空のapplication.rhtmlファイルでも作ろうものならすべての処理がスキップされます。(勉強している人はわかるかもです)

なので、何もでてこなくなったら、あなたがどこかでここに空のファイルを作成した可能性が大です。見直してみてください。